User Tools

Site Tools


hpl2:third_party_tools:3d:maya

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
hpl2:third_party_tools:3d:maya [2014/10/24 11:35]
mudbill
hpl2:third_party_tools:3d:maya [2014/10/27 08:14]
thegreatcthulhu [How to export your model]
Line 9: Line 9:
 You can download [[https://​github.com/​KhronosGroup/​OpenCOLLADA/​wiki/​OpenCOLLADA-Tools|OpenCOLLADA here]], and install it following the instructions. You can download [[https://​github.com/​KhronosGroup/​OpenCOLLADA/​wiki/​OpenCOLLADA-Tools|OpenCOLLADA here]], and install it following the instructions.
  
-Once you have installed the plugin, you must enable it. Open Maya and go to Window > Plug-ins. Find OpenCOLLADA or COLLADAMaya or similar, then check the box to enable it. This will now give you the Collada exporter option when you save your model.+Once you have installed the plugin, you must enable it. Open Maya and go to Window ​> Settings/​Preferences ​> Plug-in Manager. Find OpenCOLLADA or COLLADAMaya or similar, then check the box "​Loaded"​ and "Auto Load" ​to enable it. This will now give you the Collada exporter option when you save your model.
  
 ===== How to export your model ===== ===== How to export your model =====
Line 15: Line 15:
 Once you've made a model in Maya, you can export it using **File > Export All** (Or Export Selection if you don't want all the objects). There are a few things you must prepare first. Once you've made a model in Maya, you can export it using **File > Export All** (Or Export Selection if you don't want all the objects). There are a few things you must prepare first.
  
-    - Your model must have assigned at least 1 material. By default, a new object has a **lambert **   ​material pre-applied. If you need to assign a new or existing one, hold right click over your model and select Assign Favorite Material or **Assign New Material > Lambert**. You can also Assign Existing Material. +    - Your model must have assigned at least 1 material. By default, a new object has a **lambert **     ​material pre-applied. If you need to assign a new or existing one, hold right click over your model and select Assign Favorite Material or **Assign New Material > Lambert**. You can also Assign Existing Material. 
-    - Open your material in the **Channel Box**    and click on **Color **   ​to open the Material Type window. Select the type **File** ​   and then click the folder icon to open a browser for a texture file. The material requires a texture file. The preferred texture format is DDS (DirectDraw Surface) that can be exported through Photoshop, Gimp or Paint.NET.+    - Open your material in the **Channel Box**      and click on **Color **     ​to open the Material Type window. Select the type **File** ​     and then click the folder icon to open a browser for a texture file. The material requires a texture file. The preferred texture format is DDS (DirectDraw Surface) that can be exported through Photoshop ​([[https://​developer.nvidia.com/​nvidia-texture-tools-adobe-photoshop|Plugin]]), Gimp ([[https://​code.google.com/​p/​gimp-dds/#​Downloads|Plugin]]) ​or [[http://​getpaint.net|Paint.NET]].
     - Once you have added this, you can export your model. Open the export window, then select the OpenCOLLADA or COLLADAMaya exporter at the bottom. Use the following export settings:     - Once you have added this, you can export your model. Open the export window, then select the OpenCOLLADA or COLLADAMaya exporter at the bottom. Use the following export settings:
  
-Select **Triangulate **   ​under General Export Options.+Select **Triangulate **     ​under General Export Options.
  
-Deselect **Cameras **   ​and **Lights **   ​under Filter Export+Deselect **Cameras **     ​and **Lights **     ​under Filter Export
  
 The rest might already be set to the proper value. Compare with [[http://​i.imgur.com/​br379dS.png|this image]] (from Maya 2011). The rest might already be set to the proper value. Compare with [[http://​i.imgur.com/​br379dS.png|this image]] (from Maya 2011).
hpl2/third_party_tools/3d/maya.txt · Last modified: 2014/10/27 08:22 by thegreatcthulhu